Horde/IMP && divers

href=”http://www.horde.org” target=”_”>Horde/IMP pour le webmail d’où je travaille, je me suis heurté à un petit problème. En effet, il faut que les utilisateurs puissent utiliser deux serveurs POP3. Jusqu’ici me direz-vous rien d’extraordinaire, tu ajoutes cela dans ton fichier de config :

 # vi /etc/horde/imp4/servers.php ... 

Mon problème est apparu à moi avec le second serveur. En effet, impossible de se loguer dessus :

 Nov 28 17:43:03 XXXXXX pop3d: couriertls: /usr/lib/courier-imap/share/pop3d.pem: error:02001002:system library:fopen:No such file or directory 

OK le problème semble venir de TLS. Mais bon, de base Horde/IMP ne tente pas de se connecter en TLS, surtout que je ne lui ai pas demandé. Après pas mal de recherches sur google… Pas de solutions alors je me suis dis: “Tiens tentons de faire un petit test!”.
En effet, il y a bien “imap/notls” dans le fichier de configuration en commentaire pour expliquer mais pas : “pop3/notls”.
Essayons :

 $servers['pop2'] = array( 'name' => 'POP3 PRO MCOM', 'server' => 'XXXXXX.mcom.fr', 'protocol' => 'pop3/notls', 'port' => 110, 'maildomain' => 'mcom.fr', 'smtphost' => 'XYXYXY.mcom.fr', 'smtpport' => 25, 'realm' => '', 'preferred' => '', ); 

Et bien cela a résolu le problème et la connexion est maintenant possible! CQFD.

Bon sinon, demain et après demain cela sera silence radio sur ce blog. En effet, je pars en déplacement à partir de demain à Brest. Direction l’ENST.

Leave a Reply

Your email address will not be published.

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

This site uses Akismet to reduce spam. Learn how your comment data is processed.