Challenge OSPF

R0>sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     92.0.0.0/29 is subnetted, 1 subnets
O IA    92.42.218.0 [110/2] via 217.169.240.82, 00:01:40, FastEthernet1/1
     10.0.0.0/30 is subnetted, 1 subnets
C       10.0.0.4 is directly connected, FastEthernet1/0
     217.169.240.0/24 is variably subnetted, 2 subnets, 2 masks
S       217.169.240.32/29 [1/0] via 217.169.240.82
C       217.169.240.80/30 is directly connected, FastEthernet1/1
O E2 192.168.16.0/24 [110/20] via 217.169.240.82, 00:01:40, FastEthernet1/1
R0>

Pourquoi ?

Configurations :

R0 :

!
version 12.4
!
hostname R0
!
interface FastEthernet1/1
 ip address 217.169.240.81 255.255.255.252
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 217.169.240.81 0.0.0.0 area 0
!
ip forward-protocol nd
ip route 217.169.240.32 255.255.255.248 217.169.240.82
no ip http server
no ip http secure-server
[...]

R1 :

!
version 12.4
!
hostname R1
!
interface FastEthernet1/0
 ip address 192.168.16.1 255.255.255.0 secondary
 ip address 92.42.218.1 255.255.255.248 secondary
 ip address 217.169.240.37 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet1/1
 ip address 217.169.240.82 255.255.255.252
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 redistribute connected subnets
 redistribute static subnets
 network 217.169.240.37 0.0.0.0 area 6
 network 217.169.240.82 0.0.0.0 area 0
!
ip route 92.42.216.96 255.255.255.224 217.169.240.38
[...]

R2 :

!
version 12.4
!
hostname R2
!
interface FastEthernet1/0
 ip address 92.42.216.97 255.255.255.224
 duplex auto
 speed auto
!
interface FastEthernet1/1
 ip address 217.169.240.38 255.255.255.248
 duplex auto
 speed auto
!
ip route 0.0.0.0 0.0.0.0 217.169.240.37

Topologie GN3/Dynamips

route-redist.tar.gz

One comment on “Challenge OSPF

  • Vu qu'en un mois personne n'a trouvé:

    92.42.216.96/27 n'est pas appris par R0 car pour qu'une route de type E2 soit ajoutée depuis la table de routage OSPF vers la table de routage, il faut que le champ 'Forwarding Address' du LSA soit de type inter-area ou intra-area, s'il est non nul.

    Ici, le 'Forwarding Address' est ici à 217.169.24.38 et la route vers cette adresse est de type statique. Donc la route n'est pas ajoutée à la RIB.

    Selon la RFC 2328 section 16.4 : “If the forwarding address is non-zero, look up the forwarding address in the routing table. The matching routing table entry must specify an intra-area or inter-area path; if no such path exists, do nothing with the LSA and consider the next in the list”.

    CQFD.
    Pour plus d'informations : http://www.rfc-editor.org/cgi-bin/rfcdoctype.pl?loc=RFC&letsgo=2328&type=http&file_format=pdf

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

This site uses Akismet to reduce spam. Learn how your comment data is processed.